As I don't use OS x or gcc, I can't help with specifics. However the problem is indeed that your original compiler is out of date and doesn't support c++11, much less the current c++17 standard....