Hi !

I've created a service with VC++6 using an ATL COM AppWizard Project. The services contains a COM class. This is what a did some times before.

Everything worked fine when I've started the program from development environment. It also works fine, when I register the program as server and instaniate an object of the COM class. No Problems, the exe-file is started.

But when trying to start the programm as service the service startup fails. I could trace down the problem to the _Module.RegisterClassObjects() methods that internally calls CoRegisterClassObject() for my COM class. That call fails with an error 0x80004015 (CO_E_WRONG_SERVER_IDENTITY). I can't see the reason why, I even tried to run the service under my account (not the local system), but that won't help either.

Again, when registering as server and instaniate that class or running the exe file from command line everything works out fine.

Anybody out there that encovered the same problem or any ideas ???? it's really urgent ...