Sub-Report - Repeated input parameter prompt.
CodeGuru Home VC++ / MFC / C++ .NET / C# Visual Basic VB Forums Developer.com
Results 1 to 2 of 2

Thread: Sub-Report - Repeated input parameter prompt.

  1. #1
    Join Date
    Jan 2010
    Posts
    1

    Angry Sub-Report - Repeated input parameter prompt.

    I have 2 sub reports in detail section of the main report. They all have the same i/p parameter(date) and i have linked the i/p param of the main report with the sub report thro the change links of the sub-report command. The problem is once i run the report it prompts for the i/p again and again.....
    Does anyody have a solution to this problem


    thanks in advance

  2. #2
    Join Date
    Apr 2008
    Location
    Pittsburgh
    Posts
    103

    Re: Sub-Report - Repeated input parameter prompt.

    Check your selection formulas in the subreports. For some reason it looks like the subreports are not actually getting the parameter, and I usually find that the selection formula got messed up. Another reason could be that the link could be used in another formula somewhere, and then was changed. I had this happen once, after setting up all of the formulas on the subreport, I changed the parameter name. The formulas however did not automatically change the parameter name. Finally, recheck that the links to the subreports, just in case.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Azure Activities Information Page

Windows Mobile Development Center


Click Here to Expand Forum to Full Width

This is a CodeGuru survey question.


Featured


HTML5 Development Center