VB6.0 OCX running problem
CodeGuru Home VC++ / MFC / C++ .NET / C# Visual Basic VB Forums Developer.com
Results 1 to 9 of 9

Thread: VB6.0 OCX running problem

  1. #1
    Join Date
    Jun 2004
    Posts
    3

    Angry VB6.0 OCX running problem

    I have made an ocx . It includes the Winsock and the Timer controls . But the problem is that when I try to use the ocx in the application on some other computer the application gives error about the using the correct version of the OCX. Now when I place the ".ctl" file along with the ocx , it works fine . Now It is really annoying as i have to install complete visual basic setup on the client PC so that ".ctl" file works with ocx as app does not run only on vb runtime. Please suggest the solution.

  2. #2
    Join Date
    Jan 2006
    Location
    Chicago, IL
    Posts
    14,982

    Re: VB6.0 OCX running problem

    The CTL file probably contains LICENSING information.
    David

    CodeGuru Article: Bound Controls are Evil-VB6
    2013 Samples: MS CODE Samples

    CodeGuru Reviewer
    2006 Dell CSP
    2006, 2007 & 2008 MVP Visual Basic
    If your question has been answered satisfactorily, and it has been helpful, then, please, Rate this Post!

  3. #3
    Join Date
    Feb 2008
    Location
    Bangalore
    Posts
    149

    Re: VB6.0 OCX running problem

    Have you registered OCX?
    Encourage the efforts of fellow members by rating

    Lets not Spoon Feed and create pool of lazy programmers

    - ComIT Solutions

  4. #4
    Join Date
    Jul 2006
    Location
    Germany
    Posts
    3,722

    Re: VB6.0 OCX running problem

    Or let's extend this question: Have you made an install package with the Package and Deployment Wizard? This should usually resolve all dependancies and make a setup pack with all necessary files.

  5. #5
    Join Date
    Jun 2004
    Posts
    3

    Question Re: VB6.0 OCX running problem

    All you guys Thanks for replying,

    I have registered the OCX at the client machine . It registers successfully but app still not run , when ctl file is placed with the OCX , it runs fine.

    There is no licensing information in the ctl.


  6. #6
    Join Date
    Jun 2004
    Posts
    3

    Re: VB6.0 OCX running problem

    So far the Package and deployment option , i have tried that one too but in vain .

  7. #7
    Join Date
    Feb 2008
    Location
    Bangalore
    Posts
    149

    Re: VB6.0 OCX running problem

    First Create setup for your ocx. Install in your system where you develop your apllication.

    Open your apllication project go to refrences option in project menu, Verify the path for your user control(ocx) normally it shoud be the path where you installed your ocx or c:\windows\system32, if path is different, uncheck the selected path and by clicking Browse button select the correct path(it is not the ocx file which is in your ocx project folder).

    Recompile your application and create a new setup for the same.

    Uninstall the appllication which is currently running client system. Install the newly created setup for you application. Hope this solves your problem.
    Encourage the efforts of fellow members by rating

    Lets not Spoon Feed and create pool of lazy programmers

    - ComIT Solutions

  8. #8
    Join Date
    Jul 2006
    Location
    Germany
    Posts
    3,722

    Re: VB6.0 OCX running problem

    Another idea:
    If the ctl file was not automatically put into the Deployment Package by the wizard, you can add the file manually. You can also enter the destination path for the file manually so as it would turn up in the same folder as the ocx on the target machine.

  9. #9
    Join Date
    Feb 2008
    Location
    Bangalore
    Posts
    149

    Re: VB6.0 OCX running problem

    Quote Originally Posted by ComITSolutions View Post
    First Create setup for your ocx. Install in your system where you develop your apllication.

    Open your apllication project go to refrences option in project menu, Verify the path for your user control(ocx) normally it shoud be the path where you installed your ocx or c:\windows\system32, if path is different, uncheck the selected path and by clicking Browse button select the correct path(it is not the ocx file which is in your ocx project folder).

    Recompile your application and create a new setup for the same.

    Uninstall the appllication which is currently running client system. Install the newly created setup for you application. Hope this solves your problem.
    I am sorry, it is not refrences option, go to componets option.
    Encourage the efforts of fellow members by rating

    Lets not Spoon Feed and create pool of lazy programmers

    - ComIT Solutions

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Azure Activities Information Page

Windows Mobile Development Center


Click Here to Expand Forum to Full Width

This is a CodeGuru survey question.


Featured


HTML5 Development Center