Internet Explorer HTTPS links problem between 2 applications on same host
CodeGuru Home VC++ / MFC / C++ .NET / C# Visual Basic VB Forums Developer.com
Results 1 to 3 of 3

Thread: Internet Explorer HTTPS links problem between 2 applications on same host

  1. #1
    Join Date
    Mar 2011
    Posts
    1

    Internet Explorer HTTPS links problem between 2 applications on same host

    Hello

    I have a very strange problem over I.E (version 6 and 7).

    On one server we have apache listening HTTPS on port 443 (custom php app) and tomcat listening HTTPS on port 18443 (pentaho) and each web application have a link to the other.

    Links from 443 to 18443 are working fine, but links from 18443 to 443 are not working and we get a "page cannot be displayed" response; after this first response, refreshing the page or simply hitting again the "go" button will display the page properly. Also writing the url directly in the address bar while staying in the 18443 application would not display the page within the first try, but will do within the second try.

    the applications are reached using the ip of the host as it is an intranet environment.

    On other browser as firefox everything works ok, but we must make it work on I.E.

    Both sites certificate are not trusted but self-signed, would this be the problem?

    Any advice is welcome.

  2. #2
    PeejAvery's Avatar
    PeejAvery is offline Super Moderator Power Poster
    Join Date
    May 2002
    Posts
    10,886

    Re: Internet Explorer HTTPS links problem between 2 applications on same host

    First off, it could be an actual bug in IE. If this is the case, then it won't be fixable on your end.

    Second, why support the older browsers? I can understand wanting IE7 support, but not 6 (10 yrs old). Since IE is free, it's the client's fault if they're not willing to upgrade. Also, older browsers don't support current web standards.
    If the post was helpful...Rate it! Remember to use [code] or [php] tags.

  3. #3
    Join Date
    Feb 2011
    Location
    United States
    Posts
    1,006

    Re: Internet Explorer HTTPS links problem between 2 applications on same host

    Aye, indeed. Even Microsoft is trying to phase-out IE6: http://ie6countdown.com/
    Best Regards,

    BioPhysEngr
    http://blog.biophysengr.net
    --
    All advice is offered in good faith only. You are ultimately responsible for effects of your programs and the integrity of the machines they run on.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Windows Mobile Development Center


Click Here to Expand Forum to Full Width

This is a CodeGuru survey question.


Featured


HTML5 Development Center