dcsimg
CodeGuru Home VC++ / MFC / C++ .NET / C# Visual Basic VB Forums Developer.com
Results 1 to 5 of 5

Thread: I think I messed up BIG.

  1. #1
    Join Date
    Mar 2011
    Posts
    59

    I think I messed up BIG.

    Okay so Ive been working on a huge project all on my own, and this happens to be my first project.


    I am creating an app for windows CE 5.0 platform.

    Ive coded it in C# as per my employers instructions.

    Ive coded it in Visual Studio 2010.


    Ive now tried to install the app on the Windows CE 5.0 OS, and am unable to. I then discovered that visual studio 2010 does not support any version of windows CE. It also seems that CE may have had to have been programed in C++ for the microsoft SDK for visual studio 2008.

    Anyone have any advice or suggestions that may be able to help? Im crushed and it looks like this spells a no sleep all work weekend for me. Sadly I have a second job on the weekends that takes up most of my time as well...


    Any help would be wonderful. Thanks!

  2. #2
    Join Date
    Jun 2008
    Posts
    2,477

    Re: I think I messed up BIG.

    Quote Originally Posted by DKS1282 View Post
    Okay so Ive been working on a huge project all on my own, and this happens to be my first project.
    Ruh roh...

    Ive now tried to install the app on the Windows CE 5.0 OS, and am unable to. I then discovered that visual studio 2010 does not support any version of windows CE. It also seems that CE may have had to have been programed in C++ for the microsoft SDK for visual studio 2008.
    I don't develop for CE, but I'm pretty sure that Windows CE supports the .NET compact framework, you'll just have to use VS2008. http://connect.microsoft.com/VisualS...ment-in-vs2010
    Last edited by BigEd781; May 21st, 2011 at 12:25 AM.

  3. #3
    Join Date
    Mar 2011
    Posts
    59

    Re: I think I messed up BIG.

    Yeah I was able to convert my file to 2008 with little trouble. But the problem now lies in that I cant get it to build for the CE SDK.

    So I started to recreate the project and its going quite successfully untill I got to the part where I am adding my graphics...

    it seems almost nothing accepts "background" images or lets me set background images manually. How can I add this feature? I NEED to add my own custom images.

  4. #4
    Join Date
    Jun 2008
    Posts
    2,477

    Re: I think I messed up BIG.

    Background images for what? Typically you would draw an image to a Bitmap or use a control that is intended to display an image and set the image directly (i.e., a PictureBox).

  5. #5
    Join Date
    Mar 2011
    Posts
    59

    Re: I think I messed up BIG.

    I cant seem to set a background image to any control, button, panel, Custom user controls.

    So really what is it I have to do? put picture boxes under everything I want to have custom graphics? i didnt think I could make anything transparent in CE 5.0.

    Honestly this is a pain, has microsoft fully abandoned the CE platform? I find almost no support and even the support available from microsoft is misinformation or drivers / emulators that dont even work with their own software.


    Any help at all would help.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Windows Mobile Development Center


Click Here to Expand Forum to Full Width




On-Demand Webinars (sponsored)