I am getting following error while building . I tried searching on web as well for this error,but could not find a solution, suited for my problem. Searching on the web, I found two solutions :

1. Either use the compiler g++.
2. Add library stdc++ on the command, so that libstdc++ can be linked with.
Actually both results are almost same, since g++ itself adds libstdc++ to the command before linking.

I tried this solution, but it didn’t solve the problem. Thedifference between my problem and problem described on web is that in my case,undefined symbol is ___gxx_personality_v0$non_lazy_ptr,while all other problems described on web, describes missing___gxx_personality_v0. I tried searching for ___gxx_personality_v0$non_lazy_ptr in the libstdc++ and other libs as well using “nm”, but could not find this symbol.
If anybody has any clue about tthis problem, please let me know.

/usr/bin/cc -prebind -o PROD "other .o's" "other libs" -lgcc_eh

Undefined symbols:
"___gxx_personality_v0$non_lazy_ptr",referenced from:


Error Icould found on web :
"___gxx_personality_v0", referencedfrom: č problems other encountered was that undefined symbol was__gxx_personality_v0.
___gxx_personality_v0$non_lazy_ptrin cciIlcV9.o č In my case (see in my message), this is the undefined symbol. "std::basic_ostream<char,std::char_traits<char> >& std::endl<char,std::char_traits<char> >(std::basic_ostream<char,std::char_traits<char> >&)", referenced from:
__ZSt4endlIcSt11char_traitsIcEERSt13basic_ostreamIT_T0_ES6_$non_lazy_ptrin cciIlcV9.o
"std::ios_base::Init::~Init()",referenced from:

Thanks& Regards,