dcsimg
CodeGuru Home VC++ / MFC / C++ .NET / C# Visual Basic VB Forums Developer.com
Results 1 to 7 of 7

Thread: The table '' could not be found..

  1. #1
    Join Date
    Oct 2004
    Posts
    4

    Smile The table '' could not be found..

    Hi,

    I am using Crystal Reports 9.0 on a Windows 2000 system. I have started receiving the error

    The table '' could not be found..... for the line

    Session("oRpt").Export False
    this is the asp that calls my crystal report. The error catcher states the source is Crystal Reports ActiveX Designer.

    I am stumped on this one. This report worked 3 weeks ago and other reports in our system work. I have applied the latest hot fixes and patces but that didn't work either.

    This

    Does anyone know what that error message is trying to tell me???

    Thanks in advance for the help!!
    Mike
    Last edited by mrmartin1; May 6th, 2005 at 12:48 PM.

  2. #2
    Join Date
    Jul 2004
    Location
    Chennai, India
    Posts
    1,064

    Re: The table '' could not be found..

    GOpen the Report and in the menu Goto Database-->Verify Database
    Madhivanan

    Failing to plan is Planning to fail

  3. #3
    Join Date
    Oct 2004
    Posts
    4

    Re: The table '' could not be found..

    Hi Madhi,

    Thanks for the suggestion. I tried this and was told the database was up-to-date.

    If you have any other suggestions - please let me know!!

    Mike

  4. #4
    Join Date
    Aug 2005
    Posts
    4

    Re: The table '' could not be found..

    I had the same problem from Progress 4GL code.
    It looked as if the SQL/ODBCconnection through which I got my data didn't get all the scheme-information at once, but only the section/tables used in this one report, thus when i opened an other report in the same session it gave "Table not found".
    I resolved this by, at the end of my viewing/exporting code, executing a LogOffServer (for Progress, just before releasing my com-handles)

  5. #5
    Join Date
    Jan 2010
    Posts
    1

    Re: The table '' could not be found..

    The problem is with the subreport(s). Please login to subreports as well with the same connection Info parameters to resolve the issue under consideration. I hope it helps.

  6. #6
    Join Date
    Sep 2011
    Posts
    1

    Re: The table '' could not be found..

    Quote Originally Posted by mrmartin1 View Post
    Hi,

    I am using Crystal Reports 9.0 on a Windows 2000 system. I have started receiving the error

    The table '' could not be found..... for the line

    Session("oRpt").Export False
    this is the asp that calls my crystal report. The error catcher states the source is Crystal Reports ActiveX Designer.

    I am stumped on this one. This report worked 3 weeks ago and other reports in our system work. I have applied the latest hot fixes and patces but that didn't work either.

    This

    Does anyone know what that error message is trying to tell me???

    Thanks in advance for the help!!
    Mike


    I had the same problem using Oracle. I could resolve it giving the Grants for the view I was using.

  7. #7
    Join Date
    Nov 2011
    Posts
    1

    Smile Re: The table '' could not be found..

    Please post the complete stack trace encountered in the crystal logs.

    Also, if this can help, try going through the link:
    http://forums.sdn.sap.com/thread.jspa?threadID=1695518

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Windows Mobile Development Center


Click Here to Expand Forum to Full Width




On-Demand Webinars (sponsored)