Windows 7 mounting custom mass storage device very slow
CodeGuru Home VC++ / MFC / C++ .NET / C# Visual Basic VB Forums Developer.com
Results 1 to 3 of 3

Thread: Windows 7 mounting custom mass storage device very slow

  1. #1
    Join Date
    Jun 2012
    Location
    Canada
    Posts
    2

    Question Windows 7 mounting custom mass storage device very slow

    I have a custom developed mass storage hardware that has been working perfectly in Windows XP, *mounting with a drive letter on windows XP within seconds of plugging it in to any USB port. In windows 7 however the same hardware takes several minutes to mount. *First, in a few seconds, Windows recognises it as a USB mass Storage device when you plug it in. But if you look at the process in the action centre ( I think thats what its called, its the icon in the taskbar area on the bottom right that shows that there's a new device detected and being installed), there are two items to be installed for the device. The first has a tick and is called USB Mass Storage Device. The*second*one, the name of the actual device itself takes several minutes to finally settle on the generic, default windows driver and eventually gets a tick, causing the autorun to pop up asking if I want to open it. Like I said, it mounts like a breeze on XP but is REALLY slow on Windows 7. What is going on??
    I'm a software developer tasked with sorting this out for my client's Windows 7 clients and so far, I*have*not been able to work out what Windows 7 is doing differently to Windows XP or how I can*programmatically*fix this. They had the product developped as a mass storage device and its been working well for years on Vista with XP mode enabled for it or XP. I have NO access to the*firmware*and don't know where to start in developing a driver for this custom hardware, if that is indeed what needs to be done.. I can hbowever make some sort of program run in the installer for the software that I wrote for the chip. Basically al the software does is lets you upload and download files of a specific type (encrypted proprietary file format for this device that show up on the chip as files in its window). Theres noithing fancy going on at all and it doesn't need a device driver to run.
    What is different about the process used by Windows 7 when installing a generic mass storage device? Other flash drives I have mount much faster than this custom hardware. What is different about them? Its not the speed of the hardware, because that is not an issue on XP, as I said. Can I write the hardware id into registry*somewhere*special so Windows 7 stops mucking about looking for an*appropriate*driver EVERY time it is plugged in? Can I 'tell' Windows 7 to always use the default mass storage device and file system drivers without it getting confused and searching for 2 minutes every single time it is plugged in? Is there an ini file that could somehow be used by Windows 7 for this specific device or something like that? What do I need to do programatically to get Windows 7 to behave like Windows XP for this device only? Can I copy the default Windows mass storage device driver inf file or some other inf file and somehow decompile it and edit it to only apply to this custom flash drive? Im totally stuck right now! Help! The solution is time*sensitive*as well.

  2. #2
    Join Date
    Oct 2006
    Location
    Sweden
    Posts
    3,634

    Re: Windows 7 mounting custom mass storage device very slow

    I browsed around a bit and found this http://social.technet.microsoft.com/...d-60c8c399fa4f and one of the things that are mentioned is a drive letter collision. I've experienced this on Vista a couple years ago, maybe it's the same reason here?
    Debugging is twice as hard as writing the code in the first place.
    Therefore, if you write the code as cleverly as possible, you are, by
    definition, not smart enough to debug it.
    - Brian W. Kernighan

    To enhance your chance's of getting an answer be sure to read
    http://www.codeguru.com/forum/announ...nouncementid=6
    and http://www.codeguru.com/forum/showthread.php?t=366302 before posting

    Refresh your memory on formatting tags here
    http://www.codeguru.com/forum/misc.php?do=bbcode

    Get your free MS compiler here
    http://www.microsoft.com/visualstudio/eng/downloads

  3. #3
    Join Date
    Jun 2012
    Location
    Canada
    Posts
    2

    Re: Windows 7 mounting custom mass storage device very slow

    I don't think its a drive letter collision. There's no issues with the device after its installed, except maybe its a bit slow to respond. It picks up a drive letter no problem and plays nice. Ill checkout the link though, thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Windows Mobile Development Center


Click Here to Expand Forum to Full Width

This is a CodeGuru survey question.


Featured


HTML5 Development Center