My code runs smoothly on a x86 virtual machine but not in a x64
CodeGuru Home VC++ / MFC / C++ .NET / C# Visual Basic VB Forums Developer.com
Results 1 to 2 of 2

Thread: My code runs smoothly on a x86 virtual machine but not in a x64

  1. #1
    Join Date
    Jul 2012
    Posts
    1

    My code runs smoothly on a x86 virtual machine but not in a x64

    I'm creating a parser to compile the language Fortran but only runs correctly in a x86 windows.
    And the error is intermittent in the x64 , only gives segmentaion fault sometimes!I'm using codeblocks with mingw32-g++ .
    Any suggestions??

  2. #2
    Join Date
    Oct 2006
    Location
    Sweden
    Posts
    3,634

    Re: My code runs smoothly on a x86 virtual machine but not in a x64

    Debug your code, without it nobody here can tell you what's wrong.

    One idea could be to compile your code with MS Visual Studio. Make sure that the C/C++ option 'Detect 64-bit Portability Issues' is set in the project you create. Be aware though that 64-bit MSVC & gcc does not have the same size for all integer types.
    Debugging is twice as hard as writing the code in the first place.
    Therefore, if you write the code as cleverly as possible, you are, by
    definition, not smart enough to debug it.
    - Brian W. Kernighan

    To enhance your chance's of getting an answer be sure to read
    http://www.codeguru.com/forum/announ...nouncementid=6
    and http://www.codeguru.com/forum/showthread.php?t=366302 before posting

    Refresh your memory on formatting tags here
    http://www.codeguru.com/forum/misc.php?do=bbcode

    Get your free MS compiler here
    http://www.microsoft.com/visualstudio/eng/downloads

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Windows Mobile Development Center


Click Here to Expand Forum to Full Width

This is a CodeGuru survey question.


Featured


HTML5 Development Center