Alright I've tried everything I could think of thus far. My code works on my development machine, but when I deploy I get this error:

Problem signature:
Problem Event Name: CLR20r3
Problem Signature 01: unique.exe
Problem Signature 02:
Problem Signature 03: 50a26d61
Problem Signature 04: MySql.Data
Problem Signature 05:
Problem Signature 06: 507f04ba
Problem Signature 07: 761
Problem Signature 08: e0
Problem Signature 09: MySql.Data.MySqlClient.MySql
OS Version: 6.1.7601.
Locale ID: 1033
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789

to know:
I am using the connector / net
I am using framework 4.0
At one point it was a filenotfoundexception.

What I have tried thus far:

Installed connector / net on deployed machine
Tried messing with permissions (take owner add system everyone ect to permissions)
Tried adding the MySQL.Data.dll to local directory and using that
Tried adding reference
Tried to download the Net & Mono instead and use that dll

What I am doing:

I have added the to the reference path
then clean then build then via copy and paste over network
(if anything here could be issue let me know)

mysql database is set up to allow connection
works on dev machine without reference