In an earlier thread I had a bit of problems with Excel automation:

This, however, has been solved by installing a full MS Office 2013 rather than just Excel. So if anyone out there is missing the Excel interop and just installed Excel, try a full office, that worked for me.

Then I got:
Retrieving the COM class factory for component with CLSID {00024500-0000-0000-C000-000000000046} failed due to the following error: 80070005 Access is denied. (Exception from HRESULT: 0x80070005 (E_ACCESSDENIED)).
Which was solved thanks to this thread (in case others stumble in here) :

Now, however, I get this error:
Microsoft Excel cannot open or save any more documents because there is not enough available memory or disk space. To make more memory available, close workbooks or programs you no longer need. To free disk space, delete files you no longer need from the disk you are saving to.
Needless to say, there is loads of gigs free on the drive. It was a network drive, so I tried to change it to a local drive. Same error. I checked, that the user that runs the process (NETWORK SERVICE for my little web app) has the appropriate rights to write there. It has.

So, anyone got an idea what this could be?

Thanks in advance.