Help with DateTime and timing hiccups
CodeGuru Home VC++ / MFC / C++ .NET / C# Visual Basic VB Forums Developer.com
Results 1 to 2 of 2

Thread: Help with DateTime and timing hiccups

Threaded View

  1. #1
    Join Date
    Sep 2007
    Posts
    49

    Help with DateTime and timing hiccups

    I'm using DateTime to track elapsed time, which I realize now may not have been the best idea.

    The issue I'm having, is that something is causing my timer calls to be delayed by 13~20 seconds. (Or so I think)

    What I'm seeing is that the program's timestamp ticks by that much time. The CPU usage seems to be minimal (so it's probably not that the code hangs for that long).

    Further, if I have two instances of the program running then they will both jump at the same time.

    The other weird thing, is that while monitoring the processes with perfmon, during the pause time, the CPU usage goes blank, like the process didn't exist.

    This all started a day or so ago, and it was fine until then.

    Here's a link to the image of the perfmon.
    https://www.side-quest.com/DATA_STORAGE/perfmon.jpg

    Does anyone have any ideas on what may be causing this phenomenon?
    Last edited by Sharsnik; January 17th, 2014 at 08:41 AM.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Windows Mobile Development Center


Click Here to Expand Forum to Full Width

This is a CodeGuru survey question.


Featured


HTML5 Development Center