[RESOLVED] YA disabled control tooltip issue
CodeGuru Home VC++ / MFC / C++ .NET / C# Visual Basic VB Forums Developer.com
Results 1 to 10 of 10

Thread: [RESOLVED] YA disabled control tooltip issue

Threaded View

  1. #1
    Join Date
    Apr 2010
    Location
    Western WA, USA
    Posts
    59

    [RESOLVED] YA disabled control tooltip issue

    I know the topic of tooltips not showing for disabled controls is very "mature", and I'm reluctant to ask, but after looking at 100's of search hits, on this forum, MSDN, and others, I'm stuck.

    I see there are some workarounds for MFC and WinForms and other programming styles that I don't use, but for Win32 API code, nothing found. I basically understand why this happens (disabled controls don't get messages), but my experiments are all failures. I'm using VC8 IDE.

    For example, handling the dialog WM_MOUSEMOVE, checking ChildWindowFromPoint(), if disabled control then SendMessage(hWtip, TTM_RELAYEVENT, ...). I don't understand why this doesn't work. I'm ready to believe the older Win32 TOOLTIPS_CLASS windowproc must check the state of the control and ignore disabled ones.

    I hope someone can point me in the right direction. I mean something more specific than "check the CodeGuru controls section", which is a dead end (for API solution). Help, I'm dying here .
    Last edited by cosmicvoid; January 22nd, 2014 at 03:31 AM.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Azure Activities Information Page

Windows Mobile Development Center


Click Here to Expand Forum to Full Width

This is a CodeGuru survey question.


Featured


HTML5 Development Center