dcsimg
CodeGuru Home VC++ / MFC / C++ .NET / C# Visual Basic VB Forums Developer.com
Results 1 to 3 of 3

Thread: Stretch CView for ulta-high res screens

  1. #1
    Join Date
    Aug 2010
    Posts
    12

    Stretch CView for ulta-high res screens

    Hi,

    I recently moved a program from an old version of Visual Studio (6.0) to a new one (VS2010).
    The program is a CView.
    Now, some people who have tried to run it on ultra-high res screens have reported that the window is now displayed really tiny for them.
    This would indeed be correct, given that the window is 700x700 pixels, so it would be tiny on a 4000x???? screen.
    However, the odd thing is that the same program in Microsoft Visual Studio 6.0 appears to have been automatically stretched for them.
    Is there possibly some sort of setting or command in VS2010 where this auto-stretching is enabled?
    Or is there possibly some easy way for me to stretch the screen myself?

    Thank you in advance.

  2. #2
    Join Date
    Apr 2000
    Location
    Belgium (Europe)
    Posts
    4,626

    Re: Stretch CView for ulta-high res screens

    If your application has NOT been specifically been tagged as supporting High DPI (see Project properties, Manifest tool, Input & output, Enable DPI Awareness), then on a Windows with the screen set to high DPI, the application windows be accordingly to give the appearance of scaling.

    if your App IS set as DPI enabled, then you will need to adjust for high DPI yourself through code.

  3. #3
    Join Date
    Aug 2010
    Posts
    12

    Re: Stretch CView for ulta-high res screens

    Quote Originally Posted by OReubens View Post
    If your application has NOT been specifically been tagged as supporting High DPI (see Project properties, Manifest tool, Input & output, Enable DPI Awareness), then on a Windows with the screen set to high DPI, the application windows be accordingly to give the appearance of scaling.

    if your App IS set as DPI enabled, then you will need to adjust for high DPI yourself through code.
    Wonderful!
    Thank you very much!
    It appears that in upgrading from v6.0 to VS2013 the DPI setting was unjustly changed to "High DPI aware".
    I have now changed the setting, so hopefully this will fix the issue.

    Thanks again!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Windows Mobile Development Center


Click Here to Expand Forum to Full Width




On-Demand Webinars (sponsored)