C# App Starts in VStudio but does not Start when .exe is clicked
CodeGuru Home VC++ / MFC / C++ .NET / C# Visual Basic VB Forums Developer.com
Results 1 to 3 of 3

Thread: C# App Starts in VStudio but does not Start when .exe is clicked

  1. #1
    Join Date
    May 2003
    Location
    Fall River, MA
    Posts
    4

    C# App Starts in VStudio but does not Start when .exe is clicked

    I have a strange problem. My application starts when using VS Studio 2015. However, when I go to the bin folder to run the app, it fails to start.

    The C# application uses some .ocx objects which I register via RegSvr32 in the SysWOW64 folder.
    I then add the Components to Visual Studio Tool box, then add the Object to any GUI Form.
    Upon adding the COM objects to a form, VStudio creates both the AxHost and Interop files.

    Any help as to why the application will execute properly with no errors when run in Debugger mode via VStudio but will not run standalone.

    When I try to debug the failed instantiation by attaching the debugger, I get a wntdll.pdb not loaded error

    I remain befuddled.
    Jimi K

  2. #2
    Join Date
    Jul 2001
    Location
    Sunny South Africa
    Posts
    11,253

    Re: C# App Starts in VStudio but does not Start when .exe is clicked


  3. #3
    Arjay's Avatar
    Arjay is offline Moderator / MS MVP Power Poster
    Join Date
    Aug 2004
    Posts
    12,505

    Re: C# App Starts in VStudio but does not Start when .exe is clicked

    Does the app run in Release mode inside Visual Studio?

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Windows Mobile Development Center


Click Here to Expand Forum to Full Width

This a Codeguru.com survey!


HTML5 Development Center