We are upgrading our java from 1.6 to 1.8 . And WebSphere from to We are facing issue with the version of spring and apache cxf. We think Spring 4.1.9.RELEASE and Apache CXF 3.1.12 versions are compatible but not very sure.

need an expert opinion if the above mentioned spring and apache versions go along with Java 1.8 and WebSphere . Please suggest if there is any other version of spring and apache cxf that needs to be used.