dcsimg
CodeGuru Home VC++ / MFC / C++ .NET / C# Visual Basic VB Forums Developer.com
Results 1 to 2 of 2

Thread: Conditional breakpoint is not working

  1. #1
    Join Date
    Aug 2002
    Posts
    681

    Conditional breakpoint is not working

    Hi, ALL,
    I am using MSVC 2010 on Windows 8.1.

    I have a function which during the run has a lot of loops and conditional statements. And I need to set a breakpoint in one of the loops based on the value of a variable which is declared inside the function.

    So I set the breakpoint on the line I want and then I did a right click on the red circle (breakpoint) and selected "Condition...". Then inside the dialog shown I enter myVar == "testValue". The checkbox "Condition" is checked and the "is true" is selected.
    Then I hit "OK" and started the program.

    The breakpoint was not hit.

    What did I do wrong?

    Thank you.

  2. #2
    VictorN's Avatar
    VictorN is offline Super Moderator Power Poster
    Join Date
    Jan 2003
    Location
    Hanover Germany
    Posts
    19,228

    Re: Conditional breakpoint is not working

    What is the type of myVar ?
    Is your build an ANSI or UNICODE one?

    Additional info: http://forums.codeguru.com/showthrea...10-as-I-expect
    Victor Nijegorodov

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Windows Mobile Development Center


Click Here to Expand Forum to Full Width




On-Demand Webinars (sponsored)