dcsimg
CodeGuru Home VC++ / MFC / C++ .NET / C# Visual Basic VB Forums Developer.com
Results 1 to 7 of 7

Thread: Trouble installing old version of photoshop elements

  1. #1
    Join Date
    Nov 2019
    Posts
    3

    Trouble installing old version of photoshop elements

    I looked through the forum and didn't see anything relatable. I apologize if I missed it. I am attempting to install an xp version of photoshop elements. It worked on win7 fine. now that I am on win10 it gives me an error that I need ie 4.0 or greater Name:  Annotation 2019-11-06 105230.png
Views: 53
Size:  7.1 KB. I need to trick the installer. How?

    it will not install with compatibility modes nor administrator.

  2. #2
    Arjay's Avatar
    Arjay is offline Moderator / EX MS MVP Power Poster
    Join Date
    Aug 2004
    Posts
    13,146

    Re: Trouble installing old version of photoshop elements

    The problem is that the setup program is looking for IE 4 (or higher). Win 10 has Edge installed, not IE.

    Not sure if IE can be installed on Win 10, but you may try that.

  3. #3
    Join Date
    Nov 2019
    Posts
    3

    Re: Trouble installing old version of photoshop elements

    IE is actually installed. IE11 is in the background, stock. I am wondering now if the issue is that it is looking for a 32 bit IE and IE11 is 64bit. In either case, anyone know how to trick the system?

  4. #4
    2kaud's Avatar
    2kaud is offline Super Moderator Power Poster
    Join Date
    Dec 2012
    Location
    England
    Posts
    6,900

    Re: Trouble installing old version of photoshop elements

    What version of IE are you using on Windows 7 which works? I have IE 11 installed on my Windows 7 64 bit system.
    All advice is offered in good faith only. All my code is tested (unless stated explicitly otherwise) with the latest version of Microsoft Visual Studio (using the supported features of the latest standard) and is offered as examples only - not as production quality. I cannot offer advice regarding any other c/c++ compiler/IDE or incompatibilities with VS. You are ultimately responsible for the effects of your programs and the integrity of the machines they run on. Anything I post, code snippets, advice, etc is licensed as Public Domain https://creativecommons.org/publicdomain/zero/1.0/ and can be used without reference or acknowledgement. Also note that I only provide advice and guidance via the forums - and not via private messages!

    C++17 Compiler: Microsoft VS2019 (16.3.9)

  5. #5
    Join Date
    Nov 2019
    Posts
    3

    Re: Trouble installing old version of photoshop elements

    I do not recall. It was already installed when ie11 appeared. some crazy thing happened and I had to reinstall win10. when that happened I lost the ability to use my photoshop elements. I suppose I could reformat into win7. install everything and then upgrade back into win10. ugh, what a chore. hate doing that. I refuse to believe someone hasn't figured out a simpler way.

  6. #6
    2kaud's Avatar
    2kaud is offline Super Moderator Power Poster
    Join Date
    Dec 2012
    Location
    England
    Posts
    6,900

    Re: Trouble installing old version of photoshop elements

    The default IE for Windows 7 was IE 8. Which, if you hadn't updated, would be the one you were using. What I suspect is that there is a problem with the IE version detection in that issue of Photoshop Elements which is taking a version of IE higher than 9 (10 to 19) to be version 1. You can't install earlier versions of IE AFAIK on Windows 10. You can make IE 11 behave like earlier versions for testing etc, but that is not what you want. I suspect you either have to re-install Windows 7 then go through the upgrade process again - or use a VM for Windows 7.
    All advice is offered in good faith only. All my code is tested (unless stated explicitly otherwise) with the latest version of Microsoft Visual Studio (using the supported features of the latest standard) and is offered as examples only - not as production quality. I cannot offer advice regarding any other c/c++ compiler/IDE or incompatibilities with VS. You are ultimately responsible for the effects of your programs and the integrity of the machines they run on. Anything I post, code snippets, advice, etc is licensed as Public Domain https://creativecommons.org/publicdomain/zero/1.0/ and can be used without reference or acknowledgement. Also note that I only provide advice and guidance via the forums - and not via private messages!

    C++17 Compiler: Microsoft VS2019 (16.3.9)

  7. #7
    Arjay's Avatar
    Arjay is offline Moderator / EX MS MVP Power Poster
    Join Date
    Aug 2004
    Posts
    13,146

    Re: Trouble installing old version of photoshop elements

    Quote Originally Posted by oWNz View Post
    ugh, what a chore. hate doing that. I refuse to believe someone hasn't figured out a simpler way.
    I don't want to sound rude, but why not upgrade to a newer Photoshop version? Isn't it kind of unrealistic to expect software designed to run on an 18 year olg OS (i.e. XP) to keep running indefinitely?

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Windows Mobile Development Center


Click Here to Expand Forum to Full Width




On-Demand Webinars (sponsored)