CodeGuru Home VC++ / MFC / C++ .NET / C# Visual Basic VB Forums Developer.com
Results 1 to 5 of 5

Thread: [RESOLVED] std::map with VS 2015

Threaded View

  1. #1
    John E is offline Elite Member Power Poster
    Join Date
    Apr 2001
    Location
    Manchester, England
    Posts
    4,595

    [RESOLVED] std::map with VS 2015

    This morning I needed to open an old project in VS2015 but I couldn't seem to make anything work. So I created an empty project with just 1 x source file and added just 1 x line:-

    Code:
    #include <map>
    But the compiler gives me this message:-

    C:\Program Files (x86)\Microsoft Visual Studio 14.0\VC\include\ammintrin.h(127): error C4430: missing type specifier - int assumed. Note: C++ does not support default-int
    If I remove the #include and just compile a totally empty source file, I get no errors. Any idea what I might be doing wrong..?

    [Edit...] It's looking like it might be a namespace issue because #include <string> gives me the same error - whereas #include <cstring> is fine
    Last edited by John E; March 9th, 2020 at 06:46 AM.
    "A problem well stated is a problem half solved. - Charles F. Kettering

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  


Windows Mobile Development Center


Click Here to Expand Forum to Full Width




On-Demand Webinars (sponsored)