CodeGuru Home VC++ / MFC / C++ .NET / C# Visual Basic VB Forums
Results 1 to 2 of 2

Thread: [RESOLVED] Class not registered

  1. #1
    Join Date
    Aug 2009

    [RESOLVED] Class not registered


    I'm having quite the problem here. I'm trying to use a component in ASP (which uses Visual Basic) but I get the error "Class not registered". I have used it before on a different computer.

    The component is a DLL file, and when I type "regsvr32 ICONV.DLL" into the command prompt I get the message:
    "DllRegisterServer in ICONV.DLL succeeded."

    I have tried doing it with a local (meaning I'm sitting at the actual computer) Administrator account. When I open the registry the entry is where it should be and the "System" user account has full permission.

    When I run the ASP page, or a .vbs script in Windows (also as a local Administrator), I get the following message:

    ICONV.ICONVObject error '80040154'

    Class not registered

    /_functions.asp, line 1335

    If I then do "regsvr32 /u ICONV.DLL" I get the message:
    "DllUnregisterServer in ICONV.DLL succeeded."

    And the registry entry is gone, so it works. If I run the ASP page then I get the following message:

    Microsoft VBScript runtime error '800a01ad'

    ActiveX component can't create object: 'ICONV.ICONVObject'

    /_functions.asp, line 1321

    This means that it apparently knows when the DLL file is registered, but still says it isn't registered?

    Line 1335 in my code:

    Line 1321 in my code:
    Set ic = CreateObject("ICONV.ICONVObject")

    The "ic.Execute" command is almost the last line of the "ic block", after that "ic.Save()" is used then ic is removed from memory ("Set ic = Nothing"). Several commands are done on ic before "Execute", for example "ic.ImageWidth = 200", all of these give no error.

    I have been able to run this code when I installed the DLL file this way before, on the exact same OS (I even used the same CD to install Windows Server 2003).

    Additional things I have tried:
    + Tried installing "Microsoft .NET Framework 3.5 Service Pack 1 and .NET Framework 3.5 Family Update (KB951847) x86".
    + Tried copying the DLL file to "C:\Windows\System32\", then I placed myself in that folder in CMD and typed "regsvr32 ICONV.DLL". (Got a message that it was successfully registered.)
    None of these two tries made any difference, I still have the problem.

    Somebody please help!

  2. #2
    Join Date
    Aug 2009

    Re: Class not registered

    Never mind, problem solved, it wanted to have an application installed. Now I remember this has happened before, at which time I was also as puzzled about it as I was now. I will make a note of it.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Windows Mobile Development Center

Click Here to Expand Forum to Full Width

On-Demand Webinars (sponsored)