CodeGuru Home VC++ / MFC / C++ .NET / C# Visual Basic VB Forums Developer.com
Results 1 to 3 of 3
  1. #1
    Join Date
    Dec 2014
    Posts
    13

    How to disable optimization in Visual C++ 2010?

    I want to disable optimization in Visual C++ 2010. In gcc on Linux I could just use the -O0 switch, but in Visual C++ 2010 there are two categories of optimizations, one in the C/C++ pane and the other in the Linker pane:

    Attachment 33229

    So what settings should I choose to make sure that no optimization is being performed?
    Last edited by joseph_w; December 27th, 2014 at 01:48 AM.

  2. #2
    VictorN's Avatar
    VictorN is offline Super Moderator Power Poster
    Join Date
    Jan 2003
    Location
    Hanover Germany
    Posts
    20,118

    Re: How to disable optimization Visual C++ 2010?

    Your link Shows me the
    Invalid Attachment specified. If you followed a valid link, please notify the administrator
    Victor Nijegorodov

  3. #3
    Join Date
    Dec 2014
    Posts
    13

    Re: How to disable optimization Visual C++ 2010?

    I don't know what is the problem with the attachement. When I first uploaded the image it displayed normally, but then after a few minutes it displayed this error.
    Anyway the image just shows that in the project settings there are two categories for optimizations, one in the C/C++ and the other in the Linker.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  





Click Here to Expand Forum to Full Width

Featured