CodeGuru Home VC++ / MFC / C++ .NET / C# Visual Basic VB Forums
Results 1 to 3 of 3
  1. #1
    Join Date
    Jan 2016

    mscomctl.ocx loaded on sys, VB6 still says not loaded!

    Win7, VB6

    Everything is Regsvr32 loads fine here:


    With a copy already in Sys32 directory as well.

    But in the VB6 IDE, when I go to install component, it STILL says "object library not loaded".

    Now when I install the application I am editing, which has a treeview control, it all installs fine, the treeview is viewable.

    But when I open the .vbp file to actually work on the app, I get all that "object not registered" error on component install, of Win Common controls 6.0, or that mscomctl.ocx.

    It is registered by Regsvr32 with no error, but success message. But VB6 still does not recognize the library as loaded, thus treeview and all msconctl controls are unavailable.

    Anyone know what is causing this?

  2. #2
    DataMiser is offline Super Moderator Power Poster
    Join Date
    Jul 2008

    Re: mscomctl.ocx loaded on sys, VB6 still says not loaded!

    Create a new project in the Vb IDE
    Add a treeview control to it if possible then save the project.

    Open the vbp file of both the new project and the troublesome project with notepad
    Locate the line for the comctl reference in both and compare.

    You will likely see that there is a difference in the last digit of the ID, try changing it in the troble some project to match the one that worked then save the vbp file and try opening it in VB
    Always use [code][/code] tags when posting code.

  3. #3
    Join Date
    Jan 2016

    Re: mscomctl.ocx loaded on sys, VB6 still says not loaded!

    Thanks, I was thinking a fresh install or update to VB would be the fix. Haven't tried it yet, but I think yes.


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts

Click Here to Expand Forum to Full Width