CodeGuru Home VC++ / MFC / C++ .NET / C# Visual Basic VB Forums Developer.com
Results 1 to 6 of 6
  1. #1
    Join Date
    Jun 2011
    Posts
    38

    [RESOLVED] Problem with user controls in 16.9.2

    I created a user control with 32 buttons and loaded 16 into my main form. I couldn't get the buttons to visualize how I wanted them so changed them to panels. However I forgot to remove the controls from the main form first and ended up having to edit the designer text as it wouldn't display.
    Subsequently when I had fixed all the errors the controls were not displaying correctly and when I removed them and tried to re-load them they had disappeared from the toolbox and I can't get them back. My other projects also don't have any of my user controls in the toolbox although they work ok.
    A new project won't display user controls so something must have got disabled but I can't find where.
    Using Studio Community 2019 on Win10 - I have done a repair und upgrade to 16.9.2. Net vs 4.8.04084

  2. #2
    Join Date
    Jun 2011
    Posts
    38

    Problem with user controls in 16.9.2

    I just updated to 16.9.2 from 16.7.2 (VS2019 community) and I can't see my user controls in the toolbox. I have re-installed and tried repair but still no-go.
    The controls work (with some cosmetic problems) in my existing projects although they do not appear in toolbox.

    I wonder if I am doing something wrong but have even tried the demo calculator lib project and that doesn't work either.
    Has anybody else found this or am I just missing something obvious? (using C# but got no reply over there!)
    Last edited by RogerD; March 21st, 2021 at 08:44 PM.

  3. #3
    VictorN's Avatar
    VictorN is offline Super Moderator Power Poster
    Join Date
    Jan 2003
    Location
    Hanover Germany
    Posts
    20,100

    Re: Problem with user controls in 16.9.2

    [merged posts]
    Victor Nijegorodov

  4. #4
    VictorN's Avatar
    VictorN is offline Super Moderator Power Poster
    Join Date
    Jan 2003
    Location
    Hanover Germany
    Posts
    20,100

    Re: Problem with user controls in 16.9.2

    Quote Originally Posted by RogerD View Post
    I just updated to 16.9.2 from 16.7.2 (VS2019 community) and I can't see my user controls in the toolbox. I have re-installed and tried repair but still no-go.
    The controls work (with some cosmetic problems) in my existing projects although they do not appear in toolbox.

    I wonder if I am doing something wrong but have even tried the demo calculator lib project and that doesn't work either.
    Has anybody else found this or am I just missing something obvious? (using C# but got no reply over there!)
    Did you try to report this problem to Developer Community?
    Victor Nijegorodov

  5. #5
    Join Date
    Jun 2011
    Posts
    38

    Re: Problem with user controls in 16.9.2

    Thanks for that. I have now reported as suggested and will post any outcome.
    Regards
    RD

  6. #6
    Join Date
    Jun 2011
    Posts
    38

    Re: Problem with user controls in 16.9.2

    As I thought it was a setting in tools-options of course.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  





Click Here to Expand Forum to Full Width

Featured